App loading with blank information - Android

@Jamesj015 @robsug @pchappell246 I’ll check in with the product team and see if I can get some more info for you.

2 Likes

Has there been any updates on this? The app has always done this as long as I can remember, on my pixel 3 and now on my pixel 5. I just see it as a feature of tymit now and just automatically log into the app, close the app and open it again in order to use it. At the begining I thought it was just because the app was realitive new, but it has been some time now and it still does it.

Hi @carlos Welcome to the community, I’m a Android user as well and automatically close the App and login again each time. Yes it has been going on for a while and is still on the to fix list for Tymit, not sure when, but hopefully @Oisin will give us an update soon. It is a little annoying but there is light at the end of the tunnel.

Thanks, Yeah its been over a year now. I checked when I actually signed up to tymit and its been like it from the start. Hopefully it will get sorted soon.

Do you have any more information on this? Is there a fix planned any time soon? Thanks

I would also be interested in any updates on this @Oisin I see mention of it ongoing since last year.

It’s getting quite annoying now having to open the app twice. Would be good to see some of the android issues being addressed.

hi @Billy @carlos, the short answer is yes, we have a fix planned, but it won’t be live until we launch the new app design.

From what I understand, it’s not a straightforward fix and is best done as part of the design refresh, which isn’t too far away.

Hope that helps for now :slightly_smiling_face:

4 Likes

So your getting two for the price of one everyone. The new app design and a fix for the bug. Not to bad if I say so myself :+1:

3 Likes

That’s great, thanks for the update. I’m even more excited about the new design now :smiley:

2 Likes

Thanks for the info! Sounds great. Seems like it would be a waste of time fixing the current app with a new deisgn on the way :slight_smile:

Looking forward to seeing the new design when its ready!

3 Likes

The new design has been released but the issue hasn’t happened resolved, now it shows an error message instead of the blank screen and the only way around it is to completely kill the app and reopen it.

APP Version 1.14.1 on android 11

It’s always been like that on Android, the old design gave you a blank screen and the new design gives you an error message just to confirm it doesn’t work right.

Don’t think it’s a priority since it’s never worked properly in over a year. Just close and open again each time you want to use the app and you’ll be alright :smirk:

Or close the account and get monzo flex

How does Monzo compare with Tymit? What’s the main difference @Jamesj015

Do you still get 3 months interest free?

Are they more generous with credit limits?

How is customer service?

Is the app better?

I’ve not really looked into it so it would be good to hear a quick rundown and comparison from someone familiar with both.

3 months interest free
Maximum 12 months
Credit limit is better
Virtual card not a physical card
Minimum £3 to flex I think. There’s a lot more info on the website but you actually get customer service.

There is a clause about section 75 protection so I would look into that first too

Thanks mate, good to hear from you again btw.

I’ll have a look into it.

The important thing is it works. You can get help. The app works. It just works different to Tymit so it might not be the best replacement

One important difference is that with Monzo Flex you have to pay the first instalment immediately.

You also choose your own date for future instalments to be paid, which sounds handy, but in reality reduces the length of time for free credit.

If you choose your repayment date as the 15th of the month and buy something on the 10th April, you pay first instalment there and then, second on 15th April and third on 15th May, making the interest free period only slightly more than a month.

I get longer interest free on my traditional credit cards.

So a year later and this bug hasn’t been fixed, is it really that difficult to fix?

2 Likes