Can’t upload document to open account

I’ve just been accepted as a customer and can’t upload my passport to complete registration. I’ve tried on IPhone 11, 11 Pro and IPad and same thing happens. I take the photograph, submit it, it moves to the uploading screen and then simultaneously kicks me out and tells me ‘session expired, please login again’. It appears as though the download is still happening in the background, but it never completed the process.

Contact Support they will able to help.

Thanks Rob. I’ve tried, can’t access support through the app as I can’t get beyond the doc upload page. Going back and forth on email since Friday, but literally only get one response a day. Really frustrating.

hey @ljellis , :wave: welcome to the community
I’m going to look into this for you.

Thank you. My name is Lee Jon Ellis if you need it.

Hey Oisin
I applied and all I am getting is “We are reviewing your application?

Does it usually take 2/3 days :slight_smile:

Hey @Jamesj015 , it doesn’t usually take 2/3 days for a manual application review, but there can be delays if there’s a bit of a queue to get through. I’ll look into it and see what the team says.

1 Like

Cheers @Oisin
Thanks for checking on that

@oisin - any progress?